Requisitos do sistema

Para instalar e rodar o Drupal, seu servidor web precisa atender a alguns requisitos mínimos de sistema. Mas a maioria das empresas de hospedagem atendem aos critérios, não se preocupe ;)

Espaço em disco (Disk space)

Uma instalação mínima requer 15 MB. Um website com alguns módulos contribuídos e um tema instalados requer pelo menos 60 MB. Tenha em mente que você precisa de muito mais para o banco de dados, arquivos enviados pelo usuário (upload), mídias, backups e outros arquivos.

Servidor web (Web server)

O Drupal roda em qualquer servidor web que suporte PHP: Apache, Nginx ou Microsoft IIS.

Apache é o servidor web mais utilizado para rodar o Drupal. Por ser mais utilizado, há uma comunidade muito maior e mais capacitada para dar suporte. Por este motivo, recomenda-se o uso deste. Você pode usar a versão 2.x em ambientes UNIX/Linux, OS X ou Windows.

Drupal 7 e 6 provavelmente vão funcionar no Apache 1.3.

Mais detalhes sobre os requisitos do servidor web (inglês).

Banco de dados (Database)

  • Drupal 6: MySQL 4.1 ou maior, PostgreSQL 7.1;
  • Drupal 7: MySQL 5.0.15 maior com PDO, PostgreSQL 8.3 ou maior com PDO, SQLite 3.3.7 ou maior;
  • Drupal 8: MySQL 5.0.15/MariaDB/Percona/equivalente ou mais recente (com PDO) e uma engine de armazenamento primário compatível com InnoDB, PostgreSQL 8.3 ou maior com PDO, SQLite 3.3.7 ou maior.

Microsoft SQL Server e Oracle são suportados através de módulos adicionais.

Mais detalhes sobre os requisitos de banco de dados (inglês).

PHP

  • Drupal 6: somente PHP 5.2.x. Atenção: o suporte ao PHP 4.x foi cancelado. O núcleo do Drupal deve funcionar com PHP 5.3.x, mas PHP 5.3.x ou maior pode produzir erros ou comportamentos inesperados, especialmente para os módulos e temas contribuídos.
  • Drupal 7: PHP 5.2.5 ou maior (5.3.x recomendado).
  • Drupal 8: PHP 5.4 ou maior

Mais detalhes sobre os requisitos do PHP (inglês).

Navegue